Maestro tests on physical Android devices

Incident Report for TestingBot

Postmortem

A previous deploy introduced a bug that failed the start of Maestro tests when some conditions were met. We have added a fix, test and alert.

Posted Sep 07, 2026 - 14:09 CEST

Resolved

Maestro tests against physical Android devices were returning errors.
Posted Sep 07, 2026 - 00:30 CEST